DroidTV MX new Firmware released!

DroidTV Wizard for XBMC

Minix X7 8th FW released!


Post Reply 
 
Thread Rating:
  • 2 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Buildroot XBMC for ATV-106 Tronsmart Prometheus
10-03-2013, 01:38 AM
Post: #11
Not Solved RE: Linux Buildroot XBMC for ATV-106 Tronsmart Prometheus
Stane, thanks for your fast response. Your help here is really very appreciated. Thanks buddy!

Code:
U-Boot 2011.03(m6_mbx_v1@next) (Jan 25 2013 - 19:33:10)

aml_rtc_init
DRAM:  1 GiB
relocation Offset is: 10604000
NAND:  Amlogic nand flash uboot driver, Version U1.01.005 (c) 2010 Amlogic Inc.
No NAND device found!!!
NAND device id: 0 0 40 40 40 40
No NAND device found!!!
nand init faile: -6
MMC:   SDIO Port B: 0
SF: Unsupported manufacturer ff
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
aml_i2c_init
register usb cfg[0] = 9fe89938
Net:   Meson_Ethernet
init suspend firmware done. (ret:0)
reboot_mode=charging
SARADC open channel(4).
get_adc_sample(4): 0x3fb
get_key(): 0
Normal Start...
Hit any key to stop autoboot:  0
m6_mbx_v1#

Code:
m6_mbx_v1#sf probe 2
SF: Unsupported manufacturer ff
Failed to initialize SPI flash at 0:2

Any sf operation returns "No SPI flash selected. Please run `sf probe'". I think NAND is defective. There is any way to have linux/xbmc booting direct from SD card like on Alwinner devices?
Find all posts by this user
Quote this message in a reply
10-03-2013, 01:50 AM
Post: #12
Not Solved RE: Linux Buildroot XBMC for ATV-106 Tronsmart Prometheus
(10-03-2013 01:38 AM)Dolence Wrote:  Stane, thanks for your fast response. Your help here is really very appreciated. Thanks buddy!

Code:
U-Boot 2011.03(m6_mbx_v1@next) (Jan 25 2013 - 19:33:10)

aml_rtc_init
DRAM:  1 GiB
relocation Offset is: 10604000
NAND:  Amlogic nand flash uboot driver, Version U1.01.005 (c) 2010 Amlogic Inc.
No NAND device found!!!
NAND device id: 0 0 40 40 40 40
No NAND device found!!!
nand init faile: -6
MMC:   SDIO Port B: 0
SF: Unsupported manufacturer ff
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
aml_i2c_init
register usb cfg[0] = 9fe89938
Net:   Meson_Ethernet
init suspend firmware done. (ret:0)
reboot_mode=charging
SARADC open channel(4).
get_adc_sample(4): 0x3fb
get_key(): 0
Normal Start...
Hit any key to stop autoboot:  0
m6_mbx_v1#

Code:
m6_mbx_v1#sf probe 2
SF: Unsupported manufacturer ff
Failed to initialize SPI flash at 0:2

Any sf operation returns "No SPI flash selected. Please run `sf probe'". I think NAND is defective. There is any way to have linux/xbmc booting direct from SD card like on Alwinner devices?

We never tried to achieve that but it would be possible, sure.

SPI and NAND devices are not the same chip. You sure you're using stock Visson u-boot.bin burned on your booting sdcard?
Find all posts by this user
Quote this message in a reply
10-03-2013, 01:56 AM (This post was last modified: 10-03-2013 02:37 AM by Dolence.)
Post: #13
Not Solved RE: Linux Buildroot XBMC for ATV-106 Tronsmart Prometheus
I tried it using many many firmwares. Latest Prometheus, older, Droid TV M6... each one give same result! Right now I have linux files + Prometheus uImage_recovery inside SD card.
Thanks.

Is this SPI IC? 25l4006e
Should I replace it?
Find all posts by this user
Quote this message in a reply
03-15-2014, 07:32 AM (This post was last modified: 03-15-2014 07:35 AM by haider.)
Post: #14
Not Solved RE: Linux Buildroot XBMC for ATV-106 Tronsmart Prometheus
Tronsmart Prometheus New Stock Firmware with Win 8 UI and rooted i download this one for update but his updated but can not work with hdmi. this is last updated one. can any one help me. and i can not go back put old firmware. this is 0392013 one.
Find all posts by this user
Quote this message in a reply
03-18-2014, 12:26 AM
Post: #15
Not Solved RE: Linux Buildroot XBMC for ATV-106 Tronsmart Prometheus
(03-15-2014 07:32 AM)haider Wrote:  Tronsmart Prometheus New Stock Firmware with Win 8 UI and rooted i download this one for update but his updated but can not work with hdmi. this is last updated one. can any one help me. and i can not go back put old firmware. this is 0392013 one.

Hi,

try this firmware.

Regards,
Stane1983
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)